Changes for version 3.00_05
- Update Makefile.PL so Business::FraudDetect::preCharge is installed, included by make dist, etc.
- Phil Lobbes is responsible for the rest of the work in this release. Thanks!
- Reworked _pre_submit functionality:
- Add Class data %WrappedSubmitClassMethod to remember "wrapped" submit
- Fix new() to check %WrappedSubmitClassMethod to avoid creating deep recursion
- Used feedback from MSCHWERN / Bug #22074 to cleanup new/_pre_submit more
- Now always wrap submit() method with _pre_submit() (but only once)
- no longer populate _child_submit, code in anon sub was cleaned up
- use return values from _pre_submit to determine if real submit is called. the return values from _pre_submit should be reviewed/verified still
- _risk_detect(): explicity set return value
- _pre_submit(): explicity set return value
- Updated tests:
- 8 new tests and 1 new "MOCK3" driver for testing _pre_submit() functionality
- test for new() replacing subclass submit and causing deep recursion
- minor cleanup of test drivers
- fix "submit unchanged" test case: now wrapped with _pre_submit() always
- Updated POD documentation:
- Minor documentation change in print statements use ',' instead of '.'
- Reworked _pre_submit functionality:
Changes for version 3.00_04 - 2006-10-10
- failure statues (see notes_for_module_writers_v3)
- oops, forgot _03 changelog in _03
- B:OP:HTTPS: require Net::SSLeay 1.30 and remove _my_https_post kludge
- eliminate warnings about redefined subroutines
- Business::FraudDetect and Business::FraudDetect::preCharge included
- From Phil Lobbes:
- content() now returns empty hash if no content is defined
- build_subs now uses can() so it doesn't redefine subs (and generate warnings)
- DOC: SYNOPSIS now uses correct "card_number" and not "cardnumber"
- created test cases for (all?) methods except _risk_detect _pre_submit
- Removed some old commented out 2.x statements
- set $VERSION using eval per modperlstyle
- new() now will strip off multiple leading dashes before calling build_subs NOTE: we should probably have it remove any \W to make perl happy
- required_fields() now croaks with a list of missing fields
- Lots of general cleanup, no functional changes. "fill paragraphs" in POD, remove extra whitespace, sorted %fields, dump_contents now sorts %contents, added myself to AUTHORS.
- From Frederic Briere (closes: CPAN#21082):
- DOC: s/exp_date/expiration/
Changes for version 3.00_03 - 2005-03-16
- https_post now accepts a scalar of raw content instead of key value pairs
Changes for version 3.00_02 - 2005-01-10
- HTTPS base class now has https_post in addition to https_get
Changes for version 3.00_01 - 2004-08-26
- first of the v3 dev releases
Modules
A cohort to Business::OnlinePayment
backend for Business::FraudDetect (part of Business::OnlinePayment)
Perl extension for online payment processing
Base class for HTTPS payment APIs